Sunday, 24 January 2021

Hantek 6022BE on Peppermint 10: OpenHantek 6022

This post is about the updated version of OpenHantek software for the 6022 USB Oscilloscope.

Although restricted to the 6022BE/BL models, it has a few new features to offer.

Development of the original OpenHantek software project was brought to a halt at the end of 2018. But David Gräff & team have left us with a stable release which I'm still using on one laptop.

However, this project has been forked, and if your device is a 6022BE/BL you may be interested in the new version called: OpenHantek6022

I couldn't install this new version on my Peppermint 10 system using the Linux 64bit Deb file available on the website due to dependency issues:-

The following packages have unmet dependencies.
 openhantek : Depends: libc6 (>= 2.29) but 2.27-3ubuntu1.4 is to be installed
              Depends: libgcc-s1 (>= 3.0) but it is not installable
              Depends: libqt5core5a (>= 5.12.2) but 5.9.5+dfsg-0ubuntu2.5 is to be installed
              Depends: libqt5printsupport5 (>= 5.10.0) but 5.9.5+dfsg-0ubuntu2.5 is to be installed


So I went back to my earlier post and followed the installation method detailed here:-

 https://captainbodgit.blogspot.com/2018/03/hantek-6022be-on-lubuntu-1710-openhantek.html

...except I obviously needed to click on the "Code" button and download the zip file from here:-

https://github.com/OpenHantek/OpenHantek6022

 

This seemed to play nicely, and when I started the program from a terminal like this:-

OpenHantek  --demoMode

...up came the program in demo mode, without the need to connect my USB oscilloscope module.



There is a very good user manual which can be download from:-

 https://github.com/OpenHantek/OpenHantek6022/blob/master/docs/OpenHantek6022_User_Manual.pdf

Happy 'scoping.



No comments:

Post a comment